В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Zikeev2007
Zikeev2007
10.07.2020 12:23 •  Информатика

Напишите программу на паскале, которая выводит все простые числа в диапазоне от k до n ( 2 ≤ k ≤ n ≤ 100000 ), оканчивающиеся на цифру 3. примеры входные данные 2 30 выходные данные 3 13 23

Ответ:
evgehamorozov
evgehamorozov
03.10.2020 22:45
Var
 k,n,x,d: integer;

begin
 read(k,n);
 for x := k to n do
  if x mod 10 = 3 then
    begin
    d := 2;
    while x mod d <> 0 do d := d + 1;
    if x = d then write(x,' ');
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?