В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
денис1134
денис1134
27.11.2022 08:25 •  Информатика

Написать программу (в паскаль) , которая вводит число и выводит ее половину, четверть, одну восьмую, одну шестнадцатую.​

Ответ:
Player57
Player57
28.05.2020 23:56

1 Вариант без использования цикла

program delenie1;

var a:real;

begin

write('Введите число: ');

readln(a);

writeln('Половина: ', a/2);

writeln('Четверть: ', a/4);

writeln('Одна восьмая: ', a/8);

writeln('Одна шестнадцатая: ', a/16);

end.

2 Вариант с использованием цикла

program delenie2;

var a:real;

i:integer;

begin;

write('Введите число: ');

readln(a);

for i:=1 to 4 do

 begin

 a:= a/2;

 writeln(a);

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?