В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
sweetmalboro
sweetmalboro
31.10.2021 19:03 •  Информатика

Написать программу с использованием с++ вводится кол-во чисел < 100, а затем сами числа: 1)вывести все числа которые больше ср.ар минимального и максимального числа. 2)вывести все числакоторые меньше ср.ар всех чисел. 3)вывести все числа которые кратны 5

Ответ:
12345Serik
12345Serik
03.10.2020 22:28
#include<stdio.h>

int main(){
 int a[100],n,i,min,max,s;    
 scanf("%d",&n);
 if(n > 0){
  scanf("%d",&a[0]);
  min = max = s = a[0];
 }
 for(i = 1; i < n; i++){
  scanf("%d",&a[i]);
  s += a[i];
  if(a[i] < min) min = a[i];
  if(a[i] > max) max = a[i];     
 }
 printf("\n1: ");
 for(i = 0; i < n; i++)
  if(a[i]*2 > min + max)
  printf("%d ",a[i]);
 printf("\n2: ");
 for(i = 0; i < n; i++)
  if(a[i]*n < s)
  printf("%d ",a[i]);
 printf("\n3: ");
 for(i = 0; i < n; i++)
  if(a[i]%5 == 0)
  printf("%d ",a[i]);
 return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?