В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
GoodArtur
GoodArtur
19.04.2022 16:43 •  Информатика

Составьте программу, которая выводит на экран пример на умножение двух целых чисел, запрашивает ответ пользователя, проверяет его и выводит соответствующее сообщение: "правильно! " либо "вы ошиблись", а также правильный результат.

Ответ:
SupercellTV
SupercellTV
19.08.2020 22:22
Var
    a, b: integer;

begin
    a := Random(10);
    b := Random(10);
    write(a, ' * ', b, ' = ');
    a := a * b;
    readln(b);
    
    if a = b then writeln('Правильно')
    else writeln('Не верно. Правильный ответ ', a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?