В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
toptop54
toptop54
24.07.2022 12:16 •  Информатика

Паскаль, составить программу числа случайно в диапазоне от [-10,10] и выводятся на экран. находится сумма числе, пока число не станет равным 0.

Ответ:
Лёва9898
Лёва9898
30.09.2020 12:03
Var a,s:integer;
begin
Randomize;
a:=random(21)-10;
writeln(a);
s:=0;
while a<>0 do
 begin
 s:=s+a;
 a:=random(21)-10;
 writeln(a);  
 end;
write('s = ',s);
end.

Пример:
-6
6
10
7
-10
-8
-9
0
s = -10
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?