В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Atems564
Atems564
01.10.2022 20:59 •  Информатика

Напишите программу, которая находит номер максимального элемента массива.

Ответ:
Икари301202
Икари301202
02.08.2020 07:28
C#
int n = Convert.ToInt32(Console.ReadLine());
int max = 0;
int index = -1;
int [] mass = new int [n];
Random rnd = new Random();

for (int i = 0; i< mass.Length; i++)
{
mass[i] = rnd.Next();
Console.WriteLine(mass[i] + " ");
}

for (int i = 0; i < mass.Length; i++)
{
if (mass[i] > max)

max = mass[i];
index = i;
}
}
Console.WriteLine("Индекс наибольшего равен " + index);

короч просто описываю что надо:
1) Заводишь переменные для максимума и индекса
2) Заполняешь массив рандомными числами
3) выводишь массив
4) пробегаешь по массиву, сверяя элементы с максимумом
- если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента
5) выводишь индекс элемента

в коде все понятно будет, я думаю
но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?