В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
770glym
770glym
17.08.2022 03:05 •  Информатика

Написать программу вводит две стороны прямоугольника (целые числа). определить радиус окружности (с точностью до четырех знаков после запятой), описать около него и его периметр. сколько окружностей можно нанизать на нитку, с длинной, ровной периметру прямоугольника.

Ответ:
mkazancev228
mkazancev228
30.09.2020 05:09
Из условий я не понял про нанизывание на нитку окружностей. Остальное сделал на языке Паскаль. На своём компьютере не проверял, т.к. данный язык у меня не установлен. На фото я укзал рисунок моего понимания условий задачи.
- - - - - - - - - - - - -- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
var
     a,b : integer; {описываем длины сторон}
     r,p : real; {описываем радиус и периметр}
begin
   write ('Введите длину первой стороны прямоугольника: ');
   readln(a);
   write ('Введите длину второй стороны прямоугольника: ');
   readln(b);
   r:=(sqrt(a*a+b*b))/2; {находим радиус}
   r:=trunc(r*10000)/10000; {округляем до четырёх знаков после запятой}
   p:=(a+b)*2; {находим периметр прямоугольника};
   writeln('Радиус окружности равен: ',r);
   writeln('Периметр прямоугольника равен: ',p);
end.

Написать программу вводит две стороны прямоугольника (целые числа). определить радиус окружности (с
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?