В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
dilnoza55
dilnoza55
14.06.2021 01:08 •  Информатика

Напишите программу, которая заполняет массив из n = 10 случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу x. программа должна вывести ответ «не найден», если в массиве таких элементов нет.

Ответ:
dashameluhova95
dashameluhova95
30.09.2020 03:14
На C#

int n = 10;
int x = Convert.ToInt32(Console.ReadLine());
int [] mass = new int [n];

Random rnd = new Random();

for(int i = 0; i < mass.Length(); i++)
{
mass[i] = rnd.Next(-10, 9);
Console.WriteLine("mass[i] + " ");
}

if (mass[i] == x)
{
int index = i;
Console.WriteLine("Индекс элемента = " + index);
}
else Console.WriteLine("не найден");
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?