Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
262ник626
31.05.2021 21:38 •
Информатика
Написать программу: дано число, если оно делится на 8, увеличить его на 3, иначе уменьшить в 10 раз. результат вывести на экран.
Ответ:
urazukov
03.10.2020 20:19
Program zadacha;
var a:integer;
begin
readln (a);
if a mod 8=0
then a:=a*8
else a:=a div 10;
writeln (a);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Kroo66944
07.12.2022 19:00
На числовой прямой даны два отрезка: p = [10, 40] и q = [30, 50]. отрезок a таков, что формула ( (x ∈ а) → (x ∈ q) ) \/ (x ∈ p) тождественно истинна, то есть принимает значение 1...
Artobotik
22.04.2021 10:40
Информатика. ответьте на вопросы своими словами, без интернета плез (ну хотя бы чуть-чуть от себя). 1) Как в памяти компьютера представляются целые положительные и отрицательные числа?...
РікаРо
14.11.2022 07:03
Укажите предложение, не являющееся высказыванием: Спортом заниматься полезно Если совет разумен, то следует выполнить его Обязательно стань отличником Никакая причина не извиняет...
К123
08.11.2022 21:19
Водном классе учатся три друга, у которых есть по одному любимому предмету - , и информатика. их фамилии борисов, иванов, семенов. предметы и фамилии названы в произвольном порядке....
ilyu777
08.11.2022 21:19
Исправить ошибки в программе program n12; var x: y; real: begin write; ( введите x и y ); readln(x и y); if x 2 then y=x else 2 =x =3 if 2 =x =3 then y=2 else y=-x+5 end....
Deniza23
08.11.2022 21:19
Робот вычислитель умеет выполнять две команды: команда 1 – вычесть 3; команда 2 – умножить на 2. напиши последовательность команд, выполняя которые вычислитель может получить из числа...
dreamsk831
30.05.2021 15:57
1) объем сообщения, содержащего 20 символов, составил 100 бит. каков размер алфавита, с которого записано сообщение? 2) алфавит племени мульти состоит из 8 букв. какой объём информации...
lllllll47900732
30.05.2021 15:57
1)чем отличается понятия всемирная паутина( wide web) и понятие интернет? 2)кто изобрел всемирную паутину(www),и в каком году? 3)кем и когда был введён термин гипер текст? !...
Huliganka3009
31.10.2020 20:45
Вкодировке кои-8 каждый символ кодируется одним байтом.определите кол-во символов в сообщении , если информационный объём сообщения в этой кодировке равен 224 бит....
hzzzkzn99
24.02.2022 18:49
Найти все трехзначные числа-палиндромы. с использованием repeat (обязательно)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a:integer;
begin
readln (a);
if a mod 8=0
then a:=a*8
else a:=a div 10;
writeln (a);
end.