В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Katya149555
Katya149555
18.02.2022 05:43 •  Информатика

Дан массив( а) из n элементов , нужно удалить 1ый встретившиеся нулевой элемент из массива ( написать программу)

Ответ:
katiabrandt17
katiabrandt17
29.09.2020 23:16
Const
  n=13;
var
  a:array[1..n] of integer;
  i,k,t:integer;
begin
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to n do
    begin
    a[i]:=Random(21)-10;
    Write(a[i],' ')
    end;
  Writeln;
  { начало собственно программы }
  i:=1; k:=0;
  while (i<=n) and (k=0) do
    begin
    if a[i]=0 then k:=i;
    i:=i+1
    end;
  if k>0 then
    begin
    for i:=k to n-1 do a[i]:=a[i+1];
    Writeln('Массив-результат');
    for i:=1 to n-1 do Write(a[i],' ');
    Writeln
    end
  else
    Writeln('В массиве нет нулевых элементов')
end.

Контрольное решение
Исходный массив
6 -6 10 -9 6 9 0 10 6 0 -10 -3 6
Массив-результат
6 -6 10 -9 6 9 10 6 0 -10 -3 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?