В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу суммирования элементов массива, состоящего из 20 произвольных чисел до первого отрицательного числа. плз .

Ответ:
AQUA111
AQUA111
03.10.2020 18:57
Const n=20;
var a:array [1..n] of integer; 
s,i:integer; 
begin 
Randomize;
for i:= 1 to n do
 begin
 a[i]:=Random(21)-10;
 Write(a[i],' ')
 end;
writeln;
s:=0;
i:=1;
while (i<=n)and(a[i]>0) do 
 begin s:=s+a[i]; i:=i+1; end;
Writeln('Сумма элементов массива до первого отрицательного числа = ',s);
end.

Пример:
7 4 -5 6 -3 0 4 4 4 3 0 0 5 6 9 6 3 -9 -3 6 
Сумма элементов массива до первого отрицательного числа = 11
0,0(0 оценок)
Ответ:
Viktoria070804
Viktoria070804
03.10.2020 18:57
Program symm;uses crt;
const N=20;
var masiv:array [1..20] of integer; i:integer; summa,x:integer;begin for i:= 1 to N do   begin    masiv[i]:=Random(25)-10;    Writeln(masiv[i])   end;  for i:= 1 to N do    if (masiv[i]>0) then    begin     x:=masiv[i];     summa:=summa+x;    end    else         begin    Writeln();     Writeln('Сумма элементов массива до первого отрицательного числа=',summa);     Halt    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?