В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kseshkaShkolnikova
kseshkaShkolnikova
17.01.2023 10:13 •  Информатика

Написать программу сравнения двух строк. программа должна читать строки из файла и сравнивать нечетные и четные строки, которые следуют друг за другом.

Ответ:
sashik2005
sashik2005
28.09.2020 19:59
Var
  f:text;
  s1,s2:string;
begin
  Assign(f,'file.txt');
  Reset(f);
  while not eof(f) do
    begin
    Readln(s1);
    if not eof(f) then
      begin
      Readln(s2);
      if s1<>s2 then
        begin
        Writeln(s1);
        Writeln(s2);
        Writeln
        end
      end
    end;
  Close(f)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?