Войти
Регистрация
Спроси ai-bota
В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
Показать больше
Показать меньше
120505567890
12.11.2022 18:34 •
Информатика
Запишите на языке паскаль, си или бейсик логическое выражение , истинное при выполнении условия : заданное двузначное натуральнео число а делится на 3, а цифра 3 не входит в десятичную запись этого числа
Ответ:
Fat9l
25.08.2020 17:29
В Паскале:
(a>9) and (a<100) and (a mod 3 = 0) and (a div 10<>3) and (a mod 10 <>3)
0,0
(0 оценок)
Ответ:
bandygan666
25.08.2020 17:29
Вот вариант на VBScript, который должен сойти за басик
Если что будет не понят - спрашивайте
Function Has3Digit(number)
f = false
t = number
Do While t > 0
f = f or (t mod 10 = 3)
t = t \ 10
Loop
Has3Digit = f
End Function
number = 03
MsgBox (number mod 3 = 0) and not Has3Digit(number)
0,0
(0 оценок)
Популярные вопросы: Информатика
4elovek20000
01.01.2023 13:35
Запиши программу на языке Паскаль. Вывести на экран числа от 4 до 27 в обратном порядке. var i: integer; begin for i:= downto do writeln(); readln; end....
DimaKot2
19.11.2022 02:09
Напишите алгоритм для вот этих двух узоров в кумире, ! ( 55б.)...
Sane1999
29.01.2022 01:41
Объясните понятия авторское правобез плагиата и кратко...
Smekalenok
03.04.2021 16:00
Написать программу pascal abc в исходном файле записана речь подростка, в которой часто встречается слово паразит «ко роче», например: «мама, короче, мыла, короче, раму.» убрать...
saaafffina8902
22.01.2022 01:01
Первые 10 с мотоциклист двигался со скоростью 5 м/с, а следующие 50 с со скоростью 25 м/с. определитель среднюю скорость мотоциклиста за все время движения....
k0tesss
22.01.2022 01:01
Хлороводородная (соляная) кислота взаимодействует с. ....
irinslab
22.01.2022 01:01
Укажите коордионаты точки симметричной точке м(-3; 6)...
ndknmm
22.01.2022 01:01
Абонент пытается отправить смс-сообщение, находясь в лесу. связь плохая, и поэтому сообщение при каждой попытке отправляется с вероятностью 0,2, независимо от предыдущих попыток....
Mikich2
22.01.2022 01:01
Как называется выметывание икры рыбами...
бэйба123
22.01.2022 01:01
Подпиши,какие организмы борются с загрязнением природы человеком...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
(a>9) and (a<100) and (a mod 3 = 0) and (a div 10<>3) and (a mod 10 <>3)
Если что будет не понят - спрашивайте
Function Has3Digit(number)
f = false
t = number
Do While t > 0
f = f or (t mod 10 = 3)
t = t \ 10
Loop
Has3Digit = f
End Function
number = 03
MsgBox (number mod 3 = 0) and not Has3Digit(number)