Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
марина1087
21.06.2022 20:10 •
Информатика
Пож 1 составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с предусло-вием – while .. do).
Ответ:
ВЛАД98878
28.09.2020 19:16
Var
x0, x1, c, sum: integer;
begin
sum:=0;
readln(x0, x1, c);
while x0<=x1 do
begin
sum:=sum+x0;
x0:=x0+c;
end;
writeln(sum);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
fomenko6
17.06.2021 18:02
В какой последовательности должны располагаться служебные слова чтобы образовать правильную структуру программы на языке программирования Паскаль?...
132132456789
02.01.2020 20:43
Какое значение примет переменная Х в результате выполнения следующего фрагмента алгоритма....
Roflobara
02.01.2023 05:22
Определить чётное или нечётное число с if then else...
Ctypakelizaveta
02.12.2022 11:53
Напишите в с++ дано целое число. если оно является положительным, то прибавить к не- му 1; если отрицательным, то вычесть из него 2; если нулевым, то заме- нить его на 10. вывести...
klevchuk71p06srz
11.08.2020 12:47
Вчём опасность переустановки виндовс самому?...
ybrybrjdbx09
11.08.2020 12:47
Известно, что 31 января 2011 года было понедельником. составьте алгоритм, определяющий день недели для произвольного числа января 2011 года....
slaider1
11.10.2021 23:50
Что выбирается на рисунке? ответ введите строчными буквами в именительном падеже....
ponomareva1947
11.10.2021 06:07
Решить кроссворд По горизонтали: 2. Компьютерная программа, часть операционной системы, обеспечивающая базовые возможности управления компьютером посредством интерактивного ввода...
Анна666111
29.09.2021 03:54
Куда пойти учиться после 9 класса если хочешь в дальнейшем поступить на службу в какую либо организацию(МЧС,МВД)...
Angelochek02
08.04.2023 21:12
1/7(x+4 2/3)=9/14х-1/6это дробы Help me...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x0, x1, c, sum: integer;
begin
sum:=0;
readln(x0, x1, c);
while x0<=x1 do
begin
sum:=sum+x0;
x0:=x0+c;
end;
writeln(sum);
end.