В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Miranny
Miranny
24.02.2023 12:26 •  Информатика

Составить программу, которая бы запрашивала хнач и хкон и определяла произведение всех положительных чисел от хнач до хкон (решить , используя цикл с предусловием – while .. do). пож

Ответ:
Ардак00000000
Ардак00000000
03.10.2020 18:48
//Pascal WDE

Var
 xk,xn:real;
 i,r,xik,xin:integer;
 b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
 begin
  r:=r*i;
  b:=true;
 end;
inc(i);
end;
if b=true then write(r) else write('0');
end.

Пример ввода:
-2.8
3.8
Пример вывода:
6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?