В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Zeka211
Zeka211
22.02.2021 16:58 •  Информатика

Составить программу, выполняющую следующие действия: вводит с клавиатуры строку 'bloomedapplesandpears' (расцветали яблони и груши). определяет номер позиции, в которой находится буква r в исходной строке. меняет местами слова ' bloomed ' и 'pears'. удаляет из исходной строки подстроку 'applesand '.

Ответ:
makismunguran
makismunguran
03.10.2020 18:48
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var s:=ReadlnString('>');
  var w1:='Bloomed';
  var w2:='pears';
  var w3:='applesand';
  var i:=Pos('r',s);
  Writeln('Позиция r: ',i);
  i:=Pos(w2,s);
  s:=s[:i]+w1;
  s:=w2+s[w1.Length+1:];
  Writeln(s);
  i:=Pos(w3,s);
  Delete(s,i,w3.Length);
  Writeln(s)
end.

Тестовое решение
> Bloomedapplesandpears
Позиция r: 20
pearsapplesandBloomed
pearsBloomed
0,0(0 оценок)
Ответ:
адина56
адина56
03.10.2020 18:48
//Pascal ABC.NET 3.1 сборка 1256

Var
 s,s1:string;
begin
readln(s);
writeln(pos('r',s));
s1:='Bloomed';
delete(s,1,length(s1));
insert('pears',s,1);
delete(s,length(s)-length('pears')+1,length(s1));
insert(s1,s,length(s)+1);
writeln(s);
delete(s,pos('applesand',s),length('applesand'));
writeln(s);
end.

Вывод:
20
pearsapplesandBloomed
pearsBloomed
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?