В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ЛАПУЛЛЯ
ЛАПУЛЛЯ
30.05.2023 23:00 •  Информатика

Найти сумму положительных элементов вектора c[15]. составить программу в pascalabc

Ответ:
DashaKim123
DashaKim123
03.10.2020 18:40
//Проверил. Да, равно.
//Pascal ABC.NET 3.1 сборка 1219

Const
 n=15;

Var
 ar:array[1..n] of integer;
 i,s:integer;
begin
randomize;
 writeln('Array:');
 for i:=1 to n do
  begin
   ar[i]:=random(-10,10);
   write(ar[i]:4);
   if ar[i]>0 then s:=s+ar[i];
  end;
 writeln;
 write('Result:',s);
end.

Пример работы программы:
Array:
   3  -7   0   9  -9   6  -1   0   1   0  -7   9  -9  -5  -8
Result:28
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?