В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Таня13151814
Таня13151814
25.02.2023 19:06 •  Информатика

Составить программу на языке паскаль которая меняет местами два числа без ввода дополнительной ячейки

Ответ:
letochka111
letochka111
31.08.2020 07:23
A:=a+b;
b:=a-b;
a:=a-b;

var a,b:real;
procedure change(var a, b: real);
begin
a := a + b; writeln(a);  
b := a - b; writeln(b);  
a := a - b; writeln(a);
end;
begin
writeln('a, b:');  
readln(a, b);  
writeln('a=', a);  
writeln('b=', b);  
change(a, b);  
writeln('a=', a);  
writeln('b=', b);  
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?