В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Sima121
Sima121
05.11.2020 11:59 •  Информатика

Составьте программу на паскале.даны три различных вещественных числа,найти среднее из них.среднее число- это такое , которое больше наименьшего из данных чисел,но меньше наибольшего.

Ответ:
mgolubev13
mgolubev13
03.10.2020 18:35
//Pascal ABC.NET 3.1 сборка 1219

Var
 a,b,c:real;
begin
 read(a,b,c);
 if ((a>b) and (a<c)) or ((a<b) and (a>c)) then writeln(a);
 if ((b>a) and (b<c)) or ((b<a) and (b>c)) then writeln(b);
 if ((c>a) and (c<b)) or ((c<a) and (c>b)) then writeln(c);
end.

Пример ввода:
1.1
1.2
1.3
Пример вывода:
1.2
0,0(0 оценок)
Ответ:
ufkvkvkg
ufkvkvkg
03.10.2020 18:35
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var a,b,c:real;
  Write('Введите три числа: '); Read(a,b,c);
  Print('Среднее из чисел:');
  Seq(a,b,c).Sorted.Skip(1).Take(1).Println;
end.

Тестовое решение
Введите три числа: 5.3 2.8 10
Среднее из чисел: 5.3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?