В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
elyasfel
elyasfel
28.08.2021 07:49 •  Информатика

На языке pascalabc.net: 2) разработать программу циклической структурой в соответствии с предложенным вариантом, используя цикл с предусловием. дано действительное число х, натуральное число n. написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1! +x^2/2! +x^3/3! ++x^n/n!

Ответ:
rusakovwn
rusakovwn
03.10.2020 18:34
//PascalABC.NET 3.1 сборка 1239
begin
    var x := ReadReal('x =');
    var s := 0.0;
    var a := 1.0;
    
    for var i := 1 to ReadInteger('n =') do
    begin
        a *= x / i;
        s += a;
    end;
    writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?