В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
krasivak
krasivak
19.04.2021 18:05 •  Информатика

Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск. решить на pascalabc.net оформить в виде процедуры.

Ответ:
НастяПи
НастяПи
03.10.2020 18:39
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
procedure LinearSearch(a,b:integer;M:array of integer;
  var num:integer);
// num - номер по порядку первого элемента массива М,
// находящегося на [a;b] или 0, если такого элемента нет
begin
  num:=0;
  for var i:=0 to Length(M)-1 do
    if M[i] in [1..5] then begin num:=i+1; break end
end;

begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var i:integer;
  LinearSearch(1,5,a,i);
  if i>0 then Writeln('Элемент номер ',i,' принадлежит [1;5]')
  else Writeln('Нет элементов, принадлежащих [1;5]')
end.

Тестовое решение
n= 15
-96 50 20 -2 3 77 -48 15 99 -53 42 -45 24 44 51
Элемент номер 5 принадлежит [1;5]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?