В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
treezykilla
treezykilla
20.07.2020 18:36 •  Информатика

Написать программу на ! выбрать из текста слова в которых первая буква совпадает с последней, слова в тексте разделены пробелами

Ответ:
buzovkina81
buzovkina81
31.07.2020 23:37
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('Введите текст:');
  Writeln('Слова, в которых совпадают первая и последняя буквы:');
  s.ToWords.Where(x->x[1]=x[x.Length]).Println(NewLine)
end.

Тестовое решение
Введите текст: космос азбука     баобаб  импульс озеро  довод  конец
Слова, в которых совпадают первая и последняя буквы:
азбука
баобаб
озеро
довод
0,0(0 оценок)
Ответ:
ivanow343536373839
ivanow343536373839
31.07.2020 23:37
//Free Pascal 2.6.4

uses
  strutils;

var
  s, t: string;
  i: integer;

begin
  write('Введите текст: ');
  readln(s);
  writeln('Найденные слова: ');
  for i := 1 to WordCount(s, StdWordDelims) do
  begin
    t := ExtractWord(i, s, StdWordDelims);
    if t[1] = t[length(t)] then writeln(t);
  end;
  readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?