Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Quartz11
29.01.2020 07:21 •
Информатика
Дан массив из 20 элементов , удалить 8 элемент и подсчитать количество элементов кратных трем.
Ответ:
max500va
03.10.2020 17:36
Const
n = 20;
var
i, k: integer;
a: array[1..n] of integer;
begin
for i := 1 to n do
begin
a[i] := random(10 + 50) - 10;
write(a[i], ' ');
end;
writeln();
for i := 1 to n - 1 do
begin
if i >= 8 then
a[i] := a[i + 1];
write(a[i], ' ');
if a[i] mod 3 = 0 then k := k + 1;
end;
writeln();
writeln(k);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
POZZITIFFON34
12.11.2021 03:50
Помлгите скажите подробно, куда надо нажать, чтобы вот эти строчки сделать в ворде прям куда нажать надо...
Janeke
25.03.2022 07:58
Алфавит несет 52 буквы. какое кличество несет одна буква? решить...
darinakor140197nooii
03.07.2022 11:13
Python. Пишите кто в нём шарит...
Dementor112
05.03.2022 10:40
Объекты объектно-ориентированного графического интерфейса представляются в виде ... Укажите один или несколько правильных вариантов ответа: картинками значков иконок заранее заданными...
uliana2007zvez
07.12.2022 14:20
можно рисунок на листке ! Составьте словесный алгоритм и блок-схему для нахождения наименьшего из трех значений....
1qq
04.04.2022 14:21
Написать программу паскаля. периметр квадрата равен n см. найди длину стороны квадрата....
ilyaachkasovggp06kg1
27.12.2020 11:52
Краткая характеристика слова линейка...
sartakova2003
27.12.2020 11:52
Число 151 из десятичной в восьмеричную...
sidorova123441
27.12.2020 11:52
Линейка: назначение,форма,цвет,размер и действия подскажите !...
uchenik91
16.02.2023 14:27
По какому признаку растения делят на низшие и высшие? сравните водоросли и мхи. какие усложнения произошли в строении мхов по сравнению со строением водорослей? признаки , характерные...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n = 20;
var
i, k: integer;
a: array[1..n] of integer;
begin
for i := 1 to n do
begin
a[i] := random(10 + 50) - 10;
write(a[i], ' ');
end;
writeln();
for i := 1 to n - 1 do
begin
if i >= 8 then
a[i] := a[i + 1];
write(a[i], ' ');
if a[i] mod 3 = 0 then k := k + 1;
end;
writeln();
writeln(k);
end.