В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
rafael2003ggwp
rafael2003ggwp
08.09.2022 04:12 •  Информатика

Составить программу поиска элемента в одновимирному массиве ! турбо паскаль надо напишите код

Ответ:
Partizannn
Partizannn
27.09.2020 23:54
Программа поиска элемента в произвольном массиве:
const n=10;
var a:array[1..n+1] of integer;
p,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:4);
 end;
writeln;
write('p = '); readln(p);
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<=n
 then writeln('Искомый элемент найден, его номер = ',i)
 else writeln('Искомый элемент не найден');
end.

Пример 1:
Исходный массив:
   7  17  16  13   0   1  19  20  12   5
p = 13
Искомый элемент найден, его номер = 4

Пример 2:
Исходный массив:
  20   4   5  12  14  10  11  16  18  20
p = 15
Искомый элемент не найден
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?