В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
labzinaveronika
labzinaveronika
21.10.2021 23:32 •  Информатика

Составьте программу, которая вычисляет оптимальный вес, сравнивает его с реальным и выдаёт рекомендацию о необходимости поправиться или похудеть (с указанием, на сколько кг нужно поправиться или похудеть). оптимальный вес вычисляется по формуле: рост (в см) – 100.

Ответ:
Inpeakfhdh
Inpeakfhdh
03.10.2020 17:27
Программа ниже.
Код:
var
 rost, ves, opt: integer;
begin
  write('Введите рост: ');
 readln(rost);
 opt := rost - 100;
 write('Введите вес: ');
 readln(ves);
 if ves < opt then
   writeln('Вам нужно поправиться на ', opt - ves, ' кг.');
 if ves > opt then
   writeln('Вам нужно похудеть на ', ves - opt, ' кг.');
 if ves = opt then
   writeln('Ваш вес оптимальный');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?