В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lendo2
lendo2
09.06.2022 23:33 •  Информатика

Составьте программу, которая в массиве из 15 чисел складывает все элементы, больше 10

Ответ:
Soniasizova
Soniasizova
03.10.2020 17:19
Const
    handsfree = true;
    n = 15;

var
    a: array[1..n] of real;
    i: integer;
    sum: real;

begin
    {ввод массива}
    writeln('Данные массива:');
    for i := 1 to n do
    begin
        if handsfree then begin
            a[i] := random(100) - 50;
            write(a[i], ' ');
        end
        else readln(a[i]);
    end;
    writeln();
    
    {подсчет суммы и произведения}
    sum := 0;
    for i := 1 to n do
    begin
        if a[i] > 10 then
            sum := sum + a[i];
    end;
    writeln('sum = ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?