В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
karinaigubaeva
karinaigubaeva
26.12.2021 11:55 •  Информатика

Составить программу: найти наибольшее значение функции y=ax в квадрате+bx+c на отрезке [x1,x2]

Ответ:
Derar
Derar
03.10.2020 17:18
Var
    y, a, b, c, x, x2, h, max: real;

begin
    write('Введите a,b,c');
    readln(a, b, c);
    write('Введите x1,x2 и шаг');
    readln(x, x2, h);
    
    max := a * x * x + b * x + c;
    repeat
        y := a * x * x + b * x + c;
        if max < y then max := y;
        x := x + h;
    until x > x2;
    
    writeln(max);
end.
0,0(0 оценок)
Ответ:
Darksholnic
Darksholnic
03.10.2020 17:18
Var
 i,max,x1,x2,a,b,c:integer;
begin
 read(x1,x2,a,b,c);
 max:=-2147483648;
 for i:=x1 to x2 do
 if a*sqr(i)+b*i+c>max then max:=a*sqr(i)+b*i+c;
 writeln(max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?