В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
oksanademyanov
oksanademyanov
18.06.2020 04:43 •  Информатика

Написать программу вычисления количества ненулевых элементов одномерного массива. в c++

Ответ:
akulkaeva78
akulkaeva78
27.09.2020 16:47
#include <iostream>
using namespace std;

int main(){
    int ar[10];
    int k=0;
    for(int i=0;i<10;i++){
            cin>>ar[i];
            if(ar[i]!=0)
              k++; 
             }
     cout<<k;
     cin.get();
     cin.get();
}

Пример ввода:
1
0
0
0
0
1
1
1
1
Пример вывода:
6
0,0(0 оценок)
Ответ:
Кирито7449
Кирито7449
27.09.2020 16:47
#include <cstdlib>#include <iostream> using namespace std; void MassNullEllement(int *Mass){     int KolEl = 0 ;     for(int a=0;a<5;a++){        if(Mass[a]!=0){KolEl++;}        }     cout<<"amount element not equal zero = "<<KolEl<<"\n";    } int main(int argc, char *argv[]){    int Massiv[5];    for(int b=0;b<5;b++){            cout<<"Enter "<<b<<" element - ";
cin>>Massiv[b];           }   MassNullEllement(Massiv);    system("PAUSE");    return EXIT_SUCCESS;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?