В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
t751975
t751975
12.02.2021 00:42 •  Информатика

Написать программу в паскале: получить в убывающем порядке все двузначные числа, в десятичной записи которых нет цифры 5.

Ответ:
МисАлександра
МисАлександра
27.09.2020 11:29
Var
    i: integer;

begin
    for i := 99 downto 10 do
        if (i mod 10 <> 5) and (i div 10 <> 5) then
            write(i, ' ');
end.
0,0(0 оценок)
Ответ:
RaiderUp
RaiderUp
27.09.2020 11:29
Program dig_2_no5_downto;

var
   i,a,b: integer;

begin
  i := 99;
  while i >= 10 do
    begin
      a := i div 10;
      b := i mod 10;
      if (a <> 5) and (b <> 5) then
        write(i, ' ');
      i := i - 1;
    end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?