В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Elirgon88
Elirgon88
11.12.2020 15:58 •  Информатика

Написать программу проверяющую гипотезу сиракуза для всех чисел от n до m. значения n и m вводятся пользователем с клавиатуры. результатом работы программы является последовательность чисел заканчивающихся ( по гипотезе сиракуза) единицей.

Ответ:
gelyusya
gelyusya
25.09.2020 22:19
Var
    a, b, n, i: integer;

begin
    readln(a, b);
    for i := a to b do
    begin
        n := i;
        write(n);
        while n <> 1 do
        begin
            if (n mod 2) = 0 then
                n := n div 2
            else
                n := (3 * n + 1) div 2;
            write(' -> ', n);
        end;
        writeln;
        
    end;
end.

чесно передрано с некого сайта и доработано под задачу
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?