В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Litoli
Litoli
14.05.2021 08:16 •  Информатика

Напишите программу, которая заменяет расширение у заданного имени файла. входные данные первая строка содержит имя файла, которое нужно изменить. во второй строке записано нужное расширение. выходные данные программа должна вывести изменённое имя файла с заданным расширением. примеры входные данные qwerty exe выходные данные qwerty.exe входные данные qwetry.old.pas html выходные данные qwetry.old.html

Ответ:
динара266
динара266
03.10.2020 15:39
//Pascal ABC.NET v3.1 сборка 1219

Var
 s,sf:string;
begin
 readln(s);
 readln(sf);
 if pos('.',s)<>0 then
 delete(s,s.LastIndexOf('.')+2,length(s)-s.LastIndexOf('.'))
 else
 s+='.'; 
 writeln(concat(s,sf));
end.

Пример ввода:
point.simple.txt
pdf
Пример вывода:
point.simple.pdf
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?