В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
student2544
student2544
27.04.2021 03:21 •  Информатика

Сpascal turbo. нужно написать программунаберите программу вычисления суммы s=x+x^2++x^n и проверьте ее работу при различных значениях x и натурального n

Ответ:
keke717
keke717
03.10.2020 14:47
Var
  s, cur: longint;
  x, n, i: integer;
begin
  write('x='); read(x);
  write('n='); read(n);
  cur := 1; s := 0;
  for i := 1 to n do begin
    cur := cur * x; 
    s := s + cur;
  end;
  writeln('sum=', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?