Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
6polih1
15.10.2020 13:49 •
Информатика
Даны две последовательности символов a и b одинаковой длины. напишите программу, которая определяет, можно ли, меняя местами символы в последовательности a, получить из нее последовательность b в с++
Ответ:
raviole1983oyfuky
03.10.2020 14:47
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
int n;
out << "Vvedite n: ";
cin >> n;
vector<int> a(n), b(n);
cout << "Vvedite posl A: ";
for (int i = 0; i < n; ++i) cin >> a[i];
cout << "Vvedite posl B: ";
for (int i = 0; i < n; ++i) cin >> b[i];
sort(a.begin(), a.end());
sort(b.begin(), b.end());
cout << ((a == b) ? "Yes" : "No");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
0224n
13.03.2020 01:38
№ 3. Выполните действия: а) 11111101011, +1110000111, ; б) 11111, – 10011, ; в) 10011, 101,....
нина568
13.05.2023 11:08
Постройте таблицу истинности выражения. Даю 50б...
kerillponomarenco
17.11.2020 20:38
Осуществить перевод целых чисел из 10 с/с в указанную.147,905,2168 в 2,5,7 с/с...
шиканова
13.08.2021 01:13
Чему равно значение переменной с после выполнения алгоритма? а:= 14;б:=19;с:=б-а;с:=SORT(c) ;...
PabloDC
06.01.2022 04:32
Какова функция оперативной памяти компьютера...
RonnieHolmes
16.08.2021 17:48
Задание 3:Определи символы, соответствующие десятичному коду, и расшифруй данные слова. а) 087 111 114 100; б) 068 079 083; в) 080 097 105 110 116 098 114 117 115 104....
linkarain13
01.12.2021 23:45
Установи соответствие с видом информации:мелодия...
saksharovsasha
08.11.2021 04:09
⦁ Что такое «ячейка»? ⦁ Что такое «диапазон»? ⦁ Что такое «электронные таблицы»? можно быстро......
Dbrfsdfsd
13.03.2021 21:07
TEKCT IAAAHVI к каким заболевания может привести интернет зависимость?Выберите да правильный ответаВерных ответов: : 2простудные заболеванияаллергияпроцессорнарушение зренияПроверить...
pavlovaalina453
14.08.2021 10:12
Что из перечисленного относится к двухмерной графике? 3D-графика Растровая графика Векторная графика Фрактальная графика Выберите, что из перечисленного относится к графическим...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <vector>
#include <algorithm>
using namespace std;
int main() {
int n;
out << "Vvedite n: ";
cin >> n;
vector<int> a(n), b(n);
cout << "Vvedite posl A: ";
for (int i = 0; i < n; ++i) cin >> a[i];
cout << "Vvedite posl B: ";
for (int i = 0; i < n; ++i) cin >> b[i];
sort(a.begin(), a.end());
sort(b.begin(), b.end());
cout << ((a == b) ? "Yes" : "No");
return 0;
}