Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
ксюшка485456
14.09.2020 15:40 •
Информатика
Y=tgx при х изменяется от 0 до 10 написать программу так чтобы она решала с использованием оператора цикла
Ответ:
sereser244
07.09.2020 21:16
Const a=0; b=10;
var x,y,h:real; n,i:integer;
begin
h:=1;
n:=round((b-a)/h);
x:=a-h;
for i:=0 to n do
begin
x:=x+h;
y:=sin(x)/cos(x);
writeln(x:4:1,' ',y:6:3);
end;
end.
Результат:
0.0 0.000
1.0 1.557
2.0 -2.185
3.0 -0.143
4.0 1.158
5.0 -3.381
6.0 -0.291
7.0 0.871
8.0 -6.800
9.0 -0.452
10.0 0.648
0,0
(0 оценок)
Ответ:
mrcanxer
07.09.2020 21:16
Function tg(a:real):real;
begin
tg:=sin(a)/cos(a);
end;
var
y:real; x:integer;
begin
for x:=0 to 10 do begin
y:=tg(x);
writeln('Y=',y);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
oleshckewitchd
28.07.2022 23:14
Для составления цепочек используются бусины помеченными буквами M N O P S. сколько разных цепочек можно составить из трех бусен для которых выполняются следующие условия...
leg3
19.01.2021 19:38
Сколько чисел в ряде кодирования десятичного кода?...
dokeliz
09.06.2022 04:06
Одна ручка стоит А гривен и В копеек .Напишите программу,которая определяет,сколько ручек можно купить за С гривен и D копеек и сколько останется...
9854123g
27.06.2020 16:15
для какого из указанных значений X истинное выражение / ((x 1) и (x 7)) или (x=-8)?а) 5б) 1в) 7г) -8...
Виктория11618
16.03.2021 20:42
Какая позиция пальцев на Клавиатуре считаетсяОсновной?ываптролдфыва-олджячсм-тьбюйцук-шЩзх...
20736
01.11.2020 17:01
Переведите двоичное число 1101100 в десятичную систему счисления...
tatuxa223
15.07.2020 17:08
Кем был выпущен первый массовый персональныйКомпьютер?IntelIBMAvalonHewlett-Packard...
камран12
02.05.2021 09:31
Нужно найти ошибку в определённой строке...
wwwvadimsokol
17.01.2023 19:04
Что должен хелпер 3 предложения...
CheburekTadjik2005
11.07.2020 13:01
Какой компанией была разработана и выпущенапрограмма WORD?AppleMicrosoftIntelLibre❤...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var x,y,h:real; n,i:integer;
begin
h:=1;
n:=round((b-a)/h);
x:=a-h;
for i:=0 to n do
begin
x:=x+h;
y:=sin(x)/cos(x);
writeln(x:4:1,' ',y:6:3);
end;
end.
Результат:
0.0 0.000
1.0 1.557
2.0 -2.185
3.0 -0.143
4.0 1.158
5.0 -3.381
6.0 -0.291
7.0 0.871
8.0 -6.800
9.0 -0.452
10.0 0.648
begin
tg:=sin(a)/cos(a);
end;
var
y:real; x:integer;
begin
for x:=0 to 10 do begin
y:=tg(x);
writeln('Y=',y);
end;
end.