В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ivahinzeha475
ivahinzeha475
04.02.2020 22:44 •  Информатика

Pascal написать программу с использованием цикла с параметром. дано целое число n (> 0). найдите произведение 1/6*4/11**n^2/(n^2+2n+3) (вещественное число)

Ответ:
Artem0317q
Artem0317q
13.08.2020 23:20
\displaystyle \prod_{i=1}^n{\frac{i^2}{n^2+2n+3}}=\prod_{i=1}^n{\frac{i^2}{(i+1)^2+2}}, \quad n \in \mathbb N

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var p:=1.0;
  for var i:=1 to ReadInteger('n=') do
    p*=sqr(i)/(sqr(i+1)+2);
  Writeln(p)
end.

Тестовое решение
n= 10
0.00308222811150801
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?