Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
dimasgym
12.03.2023 20:27 •
Информатика
Написать программу на c++ для данного числа х найти минимальный делитель отличный от 1
Ответ:
Ddoj
25.09.2020 07:57
#include <iostream>
using namespace std;
int main()
{
int x;
cout <<"Введите число: ";
cin >>x;
for(int i=2; i<=x; ++i)
if(x%i==0)
{
cout <<"Наименьший делитель равен ";
cout <<i <<endl;
break;
}
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
rama13534
03.10.2022 19:58
Даны два катета прямоугольного треугольника найти его гипотенузу решите через поскаль...
garanina2005
12.03.2022 11:04
Написать на языке java 2 , никак не 1)создать массив из пяти случайных чисел в диапазоне от 15 до 150 и вычислить среднее арифметическое значение 2) программа генерирует массив...
nikdaniil04
24.11.2022 10:00
. Скопируйте части документа под названием 《Автобиография 2》 и дополните им документ под названием 《Моя семья》....
Маргошка55
01.07.2022 23:57
Решить в pascal вот : проверить, одинаковое ли число открывающих и закрывающих скобок в данной строке. перед тем как дать ответ проверьте его сами в программе работает ли и скиньте...
Fallens0n
01.07.2022 23:57
Как создать самый простой график или диаграмму чтобы была шкала процентов и варианты ответов детей чтобы в сумме получилось 90 процентов...
vitiatiger
01.07.2022 23:57
Создайте макрос в excel, который вычисляет произведение чисел, расположенных в выделенном диапазоне 5-и ячеек...
ВоительЧерноснежка
01.07.2022 23:57
Дан одномерный массив состоящий из n элементов.найти произведение и сумму элементов,квадрат которых больше 17...
konfetka7510
26.10.2021 01:41
Снаклонной плоскости высотой 8м скатывается шарик . найти скорость шарика у основания плоскости....
Angelina1409
26.10.2021 01:41
Україна в умовах наростання екологічної та політичної кризи у 1915-1917рр на україні...
arianaforever1
26.10.2021 01:41
Яфигурка небольшая точка подо мной большая кость спросить что соберетесь без меня не обойдетесь...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main()
{
int x;
cout <<"Введите число: ";
cin >>x;
for(int i=2; i<=x; ++i)
if(x%i==0)
{
cout <<"Наименьший делитель равен ";
cout <<i <<endl;
break;
}
return 0;
}