Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Арбуз2200047
06.04.2023 08:41 •
Информатика
Сос сегодня надо будьте ! паскаль работа сгенерировать случайное число из промежутка квадратная скобка150,200) и выделить его первую и последнию
Ответ:
Egorpiernand
24.09.2020 23:58
Первая цифра всегда будет = 1.
var n:integer;
begin
Randomize;
n:=random(50)+150;
writeln('n = ',n);
writeln('Первая цифра = ',n div 100);
writeln('Последняя цифра = ',n mod 10);
end.
Пример:
n = 164
Первая цифра = 1
Последняя цифра = 4
0,0
(0 оценок)
Популярные вопросы: Информатика
MigelAlemanValdes
21.12.2021 05:23
Составьте 2 программы на языке pascal,используя в одном случае оператор while,в др. случае repeat.вывести на печать положит. значения ф-ии y=sin(x)=cos(5x) для х, изменяющегося на...
zeleninalina20
15.10.2020 20:01
Укажите, для какого из указанных значений х истинно высказывание (x 10) → (50 (x+1))...
ученик1425
06.09.2021 02:06
Дано трехзначное число: 1) найти сотни, десятки и единицы, 2) найти сумму и произведение его цифр, 3) найти число, полученное при прочтении исходного числа справа налево, 4) в числе...
aSZdxcjkltr2345
06.09.2021 02:06
Внимательно рассмотрите последовательность чисел и определите, какое число является “лишним”: 16, 25, 28, 36, 49, 64, 81, 100....
отличник703
05.02.2021 02:33
Дано целое число n из n вещественных чисел. найти сумму положительных чисел из набора. с++...
Xiyneu
05.02.2021 02:33
Составить программу, которая превращает слово «систематика» в слово «» и «тема». вывести эти слова в столбик....
FoxLove666
16.10.2021 03:15
Усовершенствуйте программу тablmul таким образом, чтобы в результате выводилась оценка, поставленная ученику. критерии для выставления оценок придумайте сами. ! буду используйте: 1....
Eduardo0192837465
16.10.2021 03:15
Составьте программу для решения следующей . мальчик взял деньги на мелкие расходы в размере x р. из них y он истратил на сладости. вычислите сколько денег у него осталось? (паскаль)...
Ask2017
16.10.2021 03:15
Запишите числа в виде суммы разрядных слагаемых:...
Эзоз
01.10.2020 23:29
Пятеро участников сохранившегося в летописях аукциона приобрели по одному различному предмету (среди лотов была пудреница), уплатив разные суммы. определите покупки каждого участника,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n:integer;
begin
Randomize;
n:=random(50)+150;
writeln('n = ',n);
writeln('Первая цифра = ',n div 100);
writeln('Последняя цифра = ',n mod 10);
end.
Пример:
n = 164
Первая цифра = 1
Последняя цифра = 4