В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
PVA8485
PVA8485
04.10.2020 14:01 •  Информатика

Написать программу в паскале, массив который меняет 5 и 3 строку.

Ответ:
sayyoraibragim
sayyoraibragim
03.10.2020 13:34
Const n=6; m=4;
var 
a:array[1..n,1..m] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
  a[i,j]:=random(50);
  write(a[i,j]:4);
  end;
  writeln;
 end;
for j:=1 to m do
 begin
 c:=a[3,j]; a[3,j]:=a[5,j]; a[5,j]:=c;
 end;
writeln('Полученный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  25   4  33  17
  19  23  42   9
  36  40   1  48
  21  44  13  18
  38  29   8   7
  24  13   5  13
Полученный массив:
  25   4  33  17
  19  23  42   9
  38  29   8   7
  21  44  13  18
  36  40   1  48
  24  13   5  13
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?