В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
nezandenzar
nezandenzar
15.01.2021 08:44 •  Информатика

30 ! написать программу для определения количества корней квадратного уравнения по коэффициентам a, b, c

Ответ:
innalemesh1
innalemesh1
31.07.2020 19:29
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a,b,c:real;
  Writeln('Введите коэффициенты квадратного уравнения (a b c)');
  Read(a,b,c);
  if a=0 then begin
    Writeln('а=0 делает уравнение линейным');
    if b=0 then Writeln('Корней нет')
    else Writeln('Один корень ')
    end
  else begin
    var d:=b*b-4*a*c;
    if d<0 then Writeln('Нет действительных корней')
    else
      if d=0 then Writeln('Один корень')
      else Writeln('Два корня')
    end
end.
0,0(0 оценок)
Ответ:
happycatcom
happycatcom
31.07.2020 19:29

program yrav;

var

  a,b,c,d,x1,x2,x:real;

begin

  writeln('Введите коэффиценты квадратного уравнения');

  readln(a,b,c);

   d:=b*b-4*a*c;

   if d<0 then writeln('корней нет');

   if (d>0) and (a<>0)and (b<>0)and (c<>0) then

   begin

     x1:=(-b+sqrt(d))/(2*a);

     x2:=(-b-sqrt(d))/(2*a);

     writeln('X1= ',x1:6:3,'   X2= ',x2:6:3);

   end;

  if  (a=0)and(b<>0)and(c<>0) then

  begin

    x=-c/b;

    writeln('Один корень уравнения Х= ',x:6:3);

  end;

  if (b=0)and(c<0) and(a<>0) then

  begin

   x1=sqrt(-c/a); x2=-sqrt(-c/a);

   writeln('X1= ',x1:6:3,'   X2= ' ,x2:6:3);

  end

  else writeln('Корней нет!');

  if (a<>0) and(b<>0)and(c=0) then

  begin

   x1:=0;

   x2:=-b/a;

   writeln('X1= ', x1:6:3,'     X2= ',x2:6:3);

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?