В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
TBONBATYA
TBONBATYA
08.04.2022 16:58 •  Информатика

Решить 1. напишите программу, вычисляющую площадь прямоугольника. с клавиатуры вводятся два действительных числа - стороны прямоугольника. необходимо вычислить его площадь и вывести на экран. вывод должен быть отформатирован следующим образом: под число отводится 10 знаков, а под вещественную часть - 3. 2. с клавиатуры вводятся 3 целых числа. определить количество положи¬тельных чисел в этом наборе.

Ответ:
sveta4841
sveta4841
03.10.2020 13:10
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
{
программа, вычисляющая площадь прямоугольника.
}
var
  a,b: real;

begin
  write('Стороны прямоугольника ');
  read(a,b);
  writeln(' Площадь фигуры = ',a*b:10:3);
end.

Тестовое решение:
Стороны прямоугольника 5.3 6.7
 Площадь фигуры =     35.510

{
С клавиатуры вводятся 3 целых числа.
Определить количество положительных чисел
в этом наборе.
}
var
  a,i,n: integer;

begin
  for i:=1 to 3 do begin
  write(i,'число = ');readln(a);
  if a>0 then n:=n+1;
  end;
  writeln(' Положительных :',n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?