Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
rahcheeva81
19.12.2021 21:57 •
Информатика
На паскале. вводятся координаты x, y для n точек. определите, сколько точек в круг радиуса r. сколько точек в кольцо с меньшим радиусом r1, большим r2.
Ответ:
delmak
24.09.2020 18:59
Var x,y,R,R1,R2,rt:real;i,N,k,m :integer;begin
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Julianovikova6
10.02.2021 01:25
Решите задачу и напишите в ответе только число. Информационное сообщение объемом 1,6 Кбайта содержит 3073 символа. Каким количеством бит кодируется один символ? ответ...
СофияПодставкина
24.11.2022 10:18
Даны длины ребер а, b,c прямоугольного параллелепипеда. найти его объем v=a умножить b умножить c и площадь поверхности s= 2 умножить (а умножить b + b умножить c+ a умножить...
tanuskin798
30.11.2020 10:00
⦁имя обьекта - ⦁ назначение - ⦁ форма - ⦁ цвет - ⦁ размер - ⦁ действия - ⦁ отношения -...
sanzharzhumakhp0a0p5
08.01.2021 05:55
20 ! ! как сохранить в paint.net на windows xp рисунок в формате bmp как: 1. 24-разрядный рисунок 2. 256-цветный рисунок 3. 16-цветный рисунок...
hdblin530
07.12.2021 07:41
Скорость передачи данных через adsl-соединение равна 128.000 бит/с. определите наибольший размер файла, который может быть передан через данное соединение за 7 минут....
gilewich
09.05.2021 13:59
Может ли установщик программы не установиться из-за другого установщика старой версии этой же программы?...
15кк
25.11.2021 18:05
Сформировать массив из 12 целых чисел в диапазоне от 10 до 45 и найти сумму чисел кратных 3...
nastya84756
18.04.2023 18:38
Сочинение-рассуждение по теме Что такое взаимовыручка? 9.3 0ГЭ...
mgurbo
12.03.2023 12:46
Вычислите длину дуги окружности с радиусом 8 см если ее градусная мера равна 45 градусов...
G4wer
28.08.2022 02:57
ОЧЕНЬ НУЖНО! Прочитайте статью и заполните пропуски словами после нее. A Bad Day Yesterday I had a really bad day. I 1 at half past five, because I had to leave home early....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.