В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
greenxp
greenxp
12.04.2020 13:31 •  Информатика

Требуется написать программу для выставления оценки учащемуся за четверть. оценка выставляется как среднее арифметическое из 10 полученных оценок. каждая оценка - случайное число из промежутка от 2 до 5. использовать массив из 10 целых чисел.

Ответ:
Акжан1111111
Акжан1111111
07.08.2020 14:20
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  Print('Оценка:',ArrRandom(10,2,5).Println.Average)
end.

Тестовое решение:
3 3 5 2 3 5 3 2 4 4
Оценка: 3.4
0,0(0 оценок)
Ответ:
Антонggez
Антонggez
07.08.2020 14:20
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const n = 10;
var a:array[1..n] of integer;
i,k,s:integer;
begin
  for i:=1 to 10 do begin
    a[i]:=random(2,5); s:=s+a[i];
    write(a[i]:4);
  end;
  writeln;
  writeln('Среднее арифметическое оценок = ',s/n:0:1);
end.

Тестовое решение:
   5   2   5   2   3   4   5   4   3   5
Среднее арифметическое оценок = 3.8

А уж что поставит учитель - это его решение)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?