В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу на паскале, используя ! найти количество различных цифр данного натурального числа.

Ответ:
Танюня123125443
Танюня123125443
24.09.2020 17:59
//Pascal ABC.NET v3.1 сборка 1172

Var
 k:integer;
 se:set of char;
 s:string;
 num:set of '0'..'9';
begin
readln(s);
 num:=['0'..'9'];
 while s<>'' do
  begin
   if (not(s[length(s)] in se)) and (s[length(s)] in num) then
    begin
     inc(k);
     se:=se+[s[length(s)]];
    end;
   delete(s,length(s),1);
  end;
 writeln(k);
end.

Пример ввода:
234Мне нужно делать историю, что я тут забыл?121
Пример вывода:
4
0,0(0 оценок)
Ответ:
ladaponomareva
ladaponomareva
24.09.2020 17:59
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var s:=RegEx.Match(ReadlnString('Число:'),'\d*');
  Println('Принято число',s);
  Println('Разных цифр',s.ToString.Distinct.Count)
end.

Тестовое решение:
Число: 32647034554934932reert54654643#$%
Принято число 32647034554934932
Разных цифр 8
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?