В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
wasyr134
wasyr134
19.06.2021 21:07 •  Информатика

Паскаль. за ! с клавиатуры вводится символьная строка. определите, сколько в ней цифр

Ответ:
rambobamborap08ffj
rambobamborap08ffj
03.10.2020 12:53
Var s:string; k,i:integer;
begin
write('Введите строку:');
readln(s);
k:=0;
for i:=1 to length(s) do
 if (s[i]>='0')and(s[i]<='9') then k:=k+1;
writeln('k = ',k);
end.

Пример:
Введите строку:
13 апреля 2016 г .
k = 6
0,0(0 оценок)
Ответ:
dondokuchaev2015
dondokuchaev2015
03.10.2020 12:53
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  Write(ReadlnString('>').Where(c->c in ['0'..'9']).Count)
end.

Тестовое решение:
> Зде3сь спр14ята1ны 5 ци926ф5ры чи35сла8979 "пи"
15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?