В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Alinka291002
Alinka291002
15.07.2021 05:02 •  Информатика

Написать программу которая в последовательности целых чисел определять значение наименьшего числа из всех чисел.программа получает на вход целые положительные, числа количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода не входит в числовую последовательность). количество целых чисел не превышает 1000. все числа не превосходят 30000 . программа должна вывести: наименьшее число из всех чисел.

Ответ:
alica123434
alica123434
03.10.2020 12:43
На C++:

#include <iostream>
using namespace std;

int main()
{
int count=1, min=30001, val;
do
{
cin >>val;
if(val>30000) val-=30000;
if((val<min) && (val>0)) min=val;
if(count<1000) ++count;
} while(val>0);

cout <<"Минимальный элемент: " <<min;

return 0;
}

Написать программу которая в последовательности целых чисел определять значение наименьшего числа из
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?