В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mrdilik
mrdilik
28.06.2022 16:39 •  Информатика

Написать программу, которая запрашивает кол-во сотен, кол-во десятков, кол-во единиц, затем записывает соответствующее число, а также сумму квадратов его цифр. сделать в программе pascalabc.net

Ответ:
XXL18
XXL18
19.08.2020 16:54
Program test;
var
a,b,c,d,n:integer;
begin
Writeln('Введите кол-во сотен, десятков и единиц соответственно: ');
readln(a,b,c);
d:=a*100+b*10+c;
n:=sqr(a)+sqr(b)+sqr(c);
writeln('Сумма квадратов = ', n,#10, 'Само число: ',d);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?