В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
stanislove777
stanislove777
05.07.2022 07:26 •  Информатика

Составить программу нахождения количества положительных элементов в массиве из n вещественных чисел

Ответ:
ErikLusenko
ErikLusenko
24.09.2020 12:50
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  var a:=ArrRandomReal(ReadInteger('n='),-20,20);
  a.Println;
  Writeln('Положительных: ',a.Where(x->x>0).Count)
end.

Тестовое решение:
n= 7
-17.1342332089014 3.03964398011549 16.2039925512876 -6.95437877762801 13.9224117034685 -1.08502876995366 11.8818603045688
Положительных: 4
0,0(0 оценок)
Ответ:
Kirill316111
Kirill316111
24.09.2020 12:50
Const
  max = 20;

var
  arr : array [1..max] of real;
  count, i : integer;
begin
  for i := 1 to max do
    arr[i] := random(100) - 50;

  for i := 1 to max do
    write(arr[i], ' ');
  writeln();

  for i := 1 to max do
    if arr[i] > 0 then
       count := count + 1;

  writeln('Количество положительных чисел: ', count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?