В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
agentWINX
agentWINX
09.02.2023 07:34 •  Информатика

Написать программу для паскаля: массив а, состоящий из 10 целых элементов задан через random. все элементы массива разделить на 2 элемент. вывести на экран старый и новый массив.

Ответ:
dianochkazhikh
dianochkazhikh
18.04.2020 11:03
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=10;

Var
 ar:array[1..n] of real;
 i:integer;
 k:real;
begin
randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(100);
   write(ar[i]:4);
  end;
 k:=ar[2];
 for i:=1 to n do
  ar[i]:=ar[i]/k;
 writeln;
 writeln('Final array:');
 for i:=1 to n do
  writeln(ar[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?