В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать программу, запрашивающая 3 целых числа и выводящая сумму этих чисел, если максимум этих чисел больше 12.

Ответ:
vikusya20001
vikusya20001
03.10.2020 12:29
//Нам не обязательно находить максимум чтобы выполнить условие
//Pascal ABC.NET v3.1 сборка 1172

//Продвинутый уровень
begin
 var seq:=ReadArrInteger(3);
 if seq.any(x -> x>12)=true then writeln(seq.Sum) else writeln('Нет')
end.

//"Школьный" уровень
Var
 a,b,c:integer;
begin
 read(a,b,c);
 if (a>12) or (b>12) or (c>12) then writeln(a+b+c) else writeln('Нет');
end.

Пример ввода:
1
1
13
Пример вывода:
15
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?