Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
yablokooooo
21.11.2022 11:06 •
Информатика
Найти все двузначные числа,которые кратны числу n(программирование паскаль)
Ответ:
ushanoval
24.09.2020 12:35
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый вариант
Var
n:integer;
begin
readln(n);
range(10,99).Where(x -> x mod n=0).Print(',');
end.
//"Школьный" вариант
Var
i,n:integer;
begin
readln(n);
for i:=10 to 99 do
if i mod n=0 then write(i,',');
end.
Пример ввода:
3
Пример вывода:
12,15,18,21,24,27,30,33,36,39,42,45,48,51,54,57,60,63,66,69,72,75,78,81,84,87,90,93,96,99
0,0
(0 оценок)
Ответ:
mzachinyaeva
24.09.2020 12:35
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i:integer;
begin
write('Введите число ');
readln(a);
for i:=10 to 99 do
if i mod a = 0 then writeln(i,' кратно ',a);
end.
Тестовое решение:
Введите число 6
12 кратно 6
18 кратно 6
24 кратно 6
30 кратно 6
36 кратно 6
42 кратно 6
48 кратно 6
54 кратно 6
60 кратно 6
66 кратно 6
72 кратно 6
78 кратно 6
84 кратно 6
90 кратно 6
96 кратно 6
0,0
(0 оценок)
Популярные вопросы: Информатика
ВоительЧерноснежка
01.07.2022 23:57
Дан одномерный массив состоящий из n элементов.найти произведение и сумму элементов,квадрат которых больше 17...
vitiatiger
01.07.2022 23:57
Создайте макрос в excel, который вычисляет произведение чисел, расположенных в выделенном диапазоне 5-и ячеек...
Fallens0n
01.07.2022 23:57
Как создать самый простой график или диаграмму чтобы была шкала процентов и варианты ответов детей чтобы в сумме получилось 90 процентов...
Маргошка55
01.07.2022 23:57
Решить в pascal вот : проверить, одинаковое ли число открывающих и закрывающих скобок в данной строке. перед тем как дать ответ проверьте его сами в программе работает...
Snihdsfg
03.08.2021 20:09
Информация о средней суточной температуре воздуха за месяц задана в виде массива. определите, температура скольких дней была выше среднемесячной. напишите программу в...
NatalyaCeluh
03.08.2021 20:09
На стеллаже находится 16 полок, книга может быть поставлена на любой из них, сколько информации содержит сообщение, о том что где находится книга...
epakurtdinova
03.08.2021 20:09
Решить в pascal вот : дана последовательность из n различных целых чисел. найти сумму ее членов, расположенных между максимальным и минимальным значениями (в сумму включить...
тигренок55555
02.10.2020 07:12
Решить в pascal вот : заполните с клавиатуры массив к, состоящий из n элементов. найдите произведение четных элементов.если сделаете отправьте скриншотом из паскаль...
Настюша1лавруша
02.10.2020 07:12
C++ (оператор множественного выбора switch) написать программу, в которой пользователь вводит целое число k, а на экран выдается фраза мы нашли k грибов в лесу , согласовав...
playerkeks
02.10.2020 07:12
C++ (оператор множественного выбора switch) работа светофора для водителей запрограммирована следующим образом: начиная с начала каждого числа, в течение трех минут горит...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//Продвинутый вариант
Var
n:integer;
begin
readln(n);
range(10,99).Where(x -> x mod n=0).Print(',');
end.
//"Школьный" вариант
Var
i,n:integer;
begin
readln(n);
for i:=10 to 99 do
if i mod n=0 then write(i,',');
end.
Пример ввода:
3
Пример вывода:
12,15,18,21,24,27,30,33,36,39,42,45,48,51,54,57,60,63,66,69,72,75,78,81,84,87,90,93,96,99
var a,i:integer;
begin
write('Введите число ');
readln(a);
for i:=10 to 99 do
if i mod a = 0 then writeln(i,' кратно ',a);
end.
Тестовое решение:
Введите число 6
12 кратно 6
18 кратно 6
24 кратно 6
30 кратно 6
36 кратно 6
42 кратно 6
48 кратно 6
54 кратно 6
60 кратно 6
66 кратно 6
72 кратно 6
78 кратно 6
84 кратно 6
90 кратно 6
96 кратно 6